Windows 환경에서 Anaconda + Tensorflow 설치문제 해결하기 (No module named ‘tensorflow’ 에러 해결법)

python을 따로 설치한 다음 anaconda를 설치하고, tensorflow를 설치했다가 No module named ‘tensorflow’ 에러가 떴다. 물론 tensorflow는 실행할 수 없었다.

검색을 해보니 나와 비슷한 문제를 겪고있는 사람들이 많은듯 했다. 하지만 명확한 해결책을 제시하는 글도 찾기가 어려웠고, 어쩌다 나 혼자 이 문제를 해결하게 되어 이 글을 쓰게 되었다.

(문제의 원인을 간단히 설명하자면, anaconda는 수학과 과학 패키지를 포함한 파이썬이므로 파이썬을 먼저 설치해줄 필요가 없다. 그런데 python을 먼저 설치해버리면, anaconda에 내장된 python과 기존의 python이 충돌이 일어나 문제가 생기는 것이다. )

쉽고도 빠른 해결법은 다음과 같다.

1. 먼저, 방금전에 설치한 python과 anaconda를 깨끗하게 지운다.

이때 주의할 점은, 반드시 python측과 anaconda측에서 제공해준 uninstaller를 사용해서 지워야한다는 것이다.

  • 먼저 python부터 지워보자.  다운로드 폴더에 들어가보면 python을 설치하기 위해 사용한 실행파일이 있을 것이다. 더블클릭해서 열어보면 python 제거하기(Remove Python)가 있을 것이다.  이를 눌러주면, Python이 정상적으로 제거가 된다.
  • Anaconda를 지워보자. Anaconda2를 설치한 경우, 내PC->로컬 디스크(C:)->Program Files에 들어가자. Anaconda2 폴더가 보일 것이다. 폴더 안으로 들어가 스크롤을 내리다보면 Uninstall-Anaconda2가 있을 것이다. 이를 실행시켜주면 된다.
  • Anaconda3를 설치한 경우, 내PC->로컬 디스크(C:)로 들어가자. 그리고 창 위의 보기->표시/숨기기에서 숨긴 항목에 체크를 해준다. 그러면 ProgramData라는 폴더가 보일 것이다. ProgramData 폴더를 열어보면, Anaconda3 폴더가 보일 것이다. Anaconda3 폴더를 열어 스크롤을 쭉쭉 내리다보면 Uninstall-Anaconda3가 보일 것이다. 더블클릭하여 실행시키자.

2. 새로운 마음으로 Anaconda를 설치한다.

주의: python 홈페이지에 가서 python을 다운받지 말자. Anaconda 설치를 하면 python이 자동으로 설치가 된다.

이제 anaconda 홈페이지로 가서 다운을 받자. 64 bit 최신버전을 다운로드하도록 하자.

anaconda 다운로드 링크

다운로드 받은 실행파일을 마우스 오른쪽 버튼으로 클릭해주면, 관리자 권한으로 실행이 보일 것이다. 관리자 권한으로 실행하기를 누른 다음, 원래 설정되어있는 대로 설치를 쭉쭉 해준다. (‘다음’ 버트만 계속 누르자.)

3. Anaconda를 통해 Tensorflow를 다운받고, 실행해보자!

여기부터는 이영민님의 블로그를 참고했다.  Anaconda Prompt를 관리자 권한으로 실행한다. 이제 프롬프트창에 다음의 명령어들을 순서대로 치면 된다.

1) pip 업그레이드 하기

python -m pip install --upgrade pip

아마 최신버전이 이미 설치되어있다고 나올 것이다. (방금 아나콘다를 다운 받았으니까!)

2) conda 환경 만들기

conda create -n tensorflow python=3.7

여기서 주의할점! 지금 이 글을 쓰는 시점으로 최신 버전의 Anaconda는 python 3.6 기반인데, 독자분의 Anaconda가 python 3.x기반이다! 하면 저 명령어를 다음과 같이 수정해주면 된다.

(2018.11.22 업데이트)  tensorflow는 python 3.6 버전과 작동하고 3.7 버전은 아직 지원하질 않는다고 한다 .(https://stackoverflow.com/questions/52400391/could-not-find-a-version-that-satisfies-the-requirement-tensorflow-from-version). 그러니 가상환경을 만들 때 conda create -n tensorflow python=3.6 이라고 명령어를 쳐서 파이썬 3.6 버전으로 설치하면 되겠다.

(2019.03.08 업데이트)  이제 tensorflow가 python 3.7 버전도 지원한다고 한다. 따라서 명령어를 3.7버전에 맞게 수정하였다 (김석진님 제보 감사합니다) .  만약 독자분의 Anaconda가 python 3.x 기반이다! 하면 명령어를 다음과 같이 수정해서 사용하면 된다.

conda create -n tensorflow python=3.x

 

+ -n 뒤에는 tensorflow를 돌리기 위한 가상환경의 이름을 입력해주면 된다. 위의 경우 가상환경의 이름이 tensorflow가 되겠지만, 원하는 다른 이름을 사용해도 된다. 예를 들어  가상환경 이름을 youngjoong이라고 하고싶다면 다음과 같이 하면 된다.

conda create -n youngjoong python=3.7

3) Tensorflow 설치하기

activate tensorflow

+ 만약 가상환경 이름을 다른 이름으로 했다면, 다음과 같이 하면 된다.

activate 가상환경이름

예를 들어 youngjoong이라고 지었다면,

activate youngjoong

이라고 하면 된다.

이제 프롬프트가 tensorflow로 (혹은 본인이 지은 다른 가상환경 이름으로) 바뀔 것이다. 다음 명령어를 순서대로 쳐보자.

  • 텐서플로우 설치

pip install tensorflow

  • 파이썬 터미널 열기

python

  • 텐서플로우 패키지를 임포트

import tensorflow as tf

세팅이 완료되었다! 다들 건승하시길 🙂

 

 

 

57 Comments

  1. pip install tensorflow
    하니까
    could not find a version that satisfies the requirement tensorflow
    no matching distribution found for tensorflow
    라고 뜨면서 안대여..ㅜㅜ
    저희집컴퓨가 32비트인데 그게 문제일가요?

    좋아요

    응답

  2. (tensorflow) C:\WINDOWS\system32>pip install tensorflow
    Collecting tensorflow
    Could not find a version that satisfies the requirement tensorflow (from versions: )
    No matching distribution found for tensorflow

    ——————————————————–
    위와 같은 결과 해결 방법 있을까요?

    좋아요

    응답

    1. 원인에 따라 두가지 해결법이 있을 수 있어요.

      1) 먼저 anaconda를 설치할 당시에 64 bit 버전으로 설치해야합니다. 혹시 32 bit 버전으로 설치한 것이 아닌지 먼저 확인해보세요.

      만약 64 bit anaconda로 설치한 것이 맞으시다면

      2) tensorflow는 python 3.6 버전과 작동하고 3.7버전은 아직 지원하질 않는다고 합니다 (https://stackoverflow.com/questions/52400391/could-not-find-a-version-that-satisfies-the-requirement-tensorflow-from-version). 그러니 가상환경을 만들 때 conda create -n tensorflow python=3.6 이라고 명령어를 쳐서 파이썬 3.6 버전으로 설치해주세요.

      좋아요

      응답

      1. 답변 감사드립니다. pip install tensorflow 는 가능했는데 그 다음이 다시 문제네요..ㅠㅠ 혹시 아시나요?

        >>> import tensorflow as tf
        Traceback (most recent call last):
        File “”, line 1, in
        File “C:\Program Files\Anaconda3\envs\tensorflow\lib\site-packages\tensorflow\__init__.py”, line 24, in
        from tensorflow.python import pywrap_tensorflow # pylint: disable=unused-import
        ModuleNotFoundError: No module named ‘tensorflow.python’

        좋아요

  3. 현재 상황이 vscode에 python3.7을 설치하고 쓰고 있다가

    anaconda3를 설치한 상황에서 cmd에 tensorflow를 설치하였는데

    vscode상에서 tensorflow를 실행해보았더니 안되서 찾아보니 3.6에만 된다고하는데

    어떻게 해야할까요? 백업이 답인가요?

    좋아요

    응답

  4. 안녕하세요 글을 보면서 설치를 하는데 activate tensorflow를 입력하면 ,

    [ ‘cmd’은(는) 내부 또는 외부 명령, 실행할 수 있는 프로그램, 또는 배치 파일이 아닙니다.]
    라고 뜨는데 이것에 대한 해결방법은 무엇인지 알수있을까요??

    좋아요

    응답

  5. 안녕하세요 tensorflow 설치하는데 같은 오류가 계속 나서 댓글 남깁니다. 이런 오류가 몇번을 다시 설치해도 뜨는데 이유가 뭘까요 ㅠㅠㅠ 답글 달아주시면 감사하겠습니다.

    Python 3.6.0 |Continuum Analytics, Inc.| (default, Dec 23 2016, 11:57:41) [MSC v.1900 64 bit (AMD64)] on win32
    Type “help”, “copyright”, “credits” or “license” for more information.
    >>> import tensorflow as tf
    Traceback (most recent call last):
    File “”, line 1, in
    File “C:\Users\Cho\Anaconda3\envs\ks\lib\site-packages\tensorflow\__init__.py”, line 24, in
    from tensorflow.python import pywrap_tensorflow # pylint: disable=unused-import
    File “C:\Users\Cho\Anaconda3\envs\ks\lib\site-packages\tensorflow\python\__init__.py”, line 59, in
    from tensorflow.core.framework.graph_pb2 import *
    File “C:\Users\Cho\Anaconda3\envs\ks\lib\site-packages\tensorflow\core\framework\graph_pb2.py”, line 6, in
    from google.protobuf import descriptor as _descriptor
    File “C:\Users\Cho\Anaconda3\envs\ks\lib\site-packages\google\protobuf\descriptor.py”, line 47, in
    from google.protobuf.pyext import _message
    ImportError: DLL load failed: 지정된 프로시저를 찾을 수 없습니다.

    좋아요

    응답

    1. 해결했습니다.. 몇 일 동안 끙끙 앓았던거 해결이 되었네요ㅠㅠㅠㅠㅠㅠㅠ 다시 설치하고 다시 해보는데 가장 큰 차이점은 가상환경을 만든 후 텐서플로우를 설치하는 순서가 중요했네요… 감사합니다 (_ _)

      Liked by 1명

      응답

  6. 안녕하세요 youngjoong kwon님 저번에 질문을 남겼는데 한가지 더 궁금한게 있어서 댓글을 남기는데요.

    텐서플로우 관련 라이브러리를 최신으로 업데이트를 사용하려면 어떤 명령어를 써야하나요?

    질문이 어이가 없긴하지만..

    이 텐서플로우가 잘못 업데이트를 시키면 자꾸 안되는 경우가 생겨서 혹시나, 질문드립니다.

    감사합니다.

    좋아요

    응답

  7. 저도 동일한 증상으로 Tensorflow 설치하는 데 엄청 애를 먹었는 데 알려주신 Tip으로 Tensorflow 설치하는 데 성공했습니다. 정말 감사합니다.~

    좋아요

    응답

  8. 덕분에 해결했습니다. 정말 감사합니다. 아 그리고 2019년 3월 8일 기준으로는 tensorflow가 python 3.7버전도 지원하더라고요. 글을 수정하시면 신뢰성을 높이는데 도움이 될 것 같습니다! 다시 한 번 정말 감사드리고 좋은 하루 되세요 :~)

    좋아요

    응답

  9. 저도 똑같은 문제로 5시간 정도 헤맸는데 좋은 포스팅 감사합니다!! 근데 한가지 여쭤보고 싶은게 있습니다. 제가 주로 쥬피터 노트북이나 Spyder를 사용하는데 꼭 아나콘다 프롬프트 창에서 activate로 활성화시키고 Spyder로 들어가야 하나요? 그냥 바로 Spyder나 쥬피터 노트북 실행해서 import tensorflow as tf 하면 import가 안되더라구요..너무 귀찮은데 무슨 방법이 없을까요 ㅠㅠ

    좋아요

    응답

    1. 제 튜토리얼에서 가상환경 만드는 부분만 생략하고 따라하시면 됩니다. 하지만 저는 가상환경을 먼저 만들고 프로젝트를 하는 것을 추천드립니다.

      여러가지 프로젝트를 진행할때, 각각의 프로젝트마다 필요한 라이브러리들이 다를 수도 있고, 기존의 라이브러리를 업데이트해줘야 할 때도 있습니다. 그때마다 원래 환경에 새로운 라이브러리들을 깔거나, 업데이트를 하면 기존의 다른 라이브러리들과 충돌을 할 수가 있습니다. 또한 특정 프로젝트가 요구하는 라이브러리 버전과 다른 프로젝트가 요구하는 라이브러리의 버전이 달라지는 문제도 생길 수 있습니다. 이러한 문제들이 발생하면 해결하는데 시간이 많이 소요됩니다.

      그렇기 때문에 각 프로젝트의 목적에 맞게끔 가상환경을 만드시고, 가상환경 위에서 프로젝트를 하시는 것을 추천드립니다.

      https://uoa-eresearch.github.io/eresearch-cookbook/recipe/2014/11/20/conda/

      이 링크의 글을 읽어보시면 도움이 되실듯 합니다.

      좋아요

      응답

  10. 안녕하세요.

    제가 tensorflow gpu 버전을 설치 시도 중인데

    적어주신 글 마지막 부분에서 pip install tensorflow-gpu로 하고 설치하여

    import tensorflow as tf라고 하면

    DLL load failed : 지정된 모듈을 찾을 수 없습니다.라는 경고문이 뜹니다.

    cuda나 cuDNN같은 설정은 다른 곳에서 하라는 데로 해 놓은 상태인데.

    왜 그러는지 혹시 알수있을까요??

    좋아요

    응답

  11. 정말 감사합니다…. 6시간을 되지도 않는 영어 읽어가며 구글링하다가 이 글 보고 한번에 해결했습니다.
    저두 파이썬 설치하구 아나콘다 설치한 경우라 다시 지웠다 해야되나 싶었는데, conda 환경만들어주면 해결 가능하네요!! 감사합니다

    좋아요

    응답

  12. 리눅스 아나콘다환경으로 주피터노트북 실행해서 텐서플로 임포트 시도하다가 안되서 계속 헤맸는데 덕분에 해결했습니다. 감사합니다!!

    좋아요

    응답

  13. 감사합니다….. 케라스랑 텐서플로우때문에 별의별짓을 다하다..

    충돌때문이었군요,,

    ( VS랑.. 아나콘다랑 Python, Pycharm 요것들이..뭔가가 충돌을 일으켯나봅니다..)

    좋아요

    응답

  14. 왜 파이참에선 모듈이 없다고 뜨죠 ㅠㅠ 이 대로 해서 다시 전부 다 지우고 아나콘다만 다시 설치해서 했는데 파이참에선 아무리 interpret바꾸고 뭐 해도 안되네요 ㅠㅠ 모듈없다고뜨네요

    좋아요

    응답

  15. 떙큐! 해결했어요. 다만 아나콘다를 재설치할떄 5.3.1을 설치하지않으면, 텐서플로우 설치시 SSL Error가 나니 다른 사람들은 참고해주세요.

    좋아요

    응답

  16. 도움이 됬습니다. 다만 아나콘다 재 설치시 5.3.1로 하지않으면, 텐서플로우 설치시 SSL Error와 직면할수있습니다.
    이점 유의해서 새로 설치하시는분들은 5.3.1로 받으시길 권장드립니다.

    좋아요

    응답

  17. 감사합니다 ㅠㅠㅠㅠㅠㅠㅠ 과제 마감일 며칠 전에 실수로 삭제해서 멘탈 다 뽀개져가는 통에 은혜 입어갑니다…

    좋아요

    응답

    1. Tensorflow 에러 – ImportError: DLL load failed 오류 뜨신 분들은 아마도 Nvidia를 사용하는 PC에서 문제가 발생하고 이 경우 설치된 tensorflow을 제거해준 후 다음처럼 Tensorflow 2.0을 설치하도록 지정해주면 문제가 해결됩니다.
      pip install tensorflow==2.0

      좋아요

      응답

  18. 마지막 단계쯤에서 파이선을 실행 어떻게 시키는건가요?? 다지우고 아나콘다만 다운받았는데 파이선은 어디에도 없어서요ㅠㅠ

    좋아요

    응답

  19. 안녕하세요 : )
    ImportError: DLL load failed: 지정된 모듈을 찾을 수 없습니다.
    저도 비슷한 에러 때문에,, anaconda를 삭제할까 했었다가, 혹시나 하는 마음으로 (재설치가 너무 귀찮아서)
    기존 가상환경을 삭제하고, 새로이 가상환경을 생성한 후 (python version = 3.7)
    pip install tensorflow=2.0 으로 버전을 넣어주고 설치하니까, 임포트가 잘되더라구요.
    비슷한분들 한번 참고하시면 좋을것 같아서 글 남깁니다. : )

    그리고 상세히 남겨주신 YOUNGJOONG 님에게도 감사함을 전해드립니다. 좋은 하루 보내세요.

    좋아요

    응답

  20. 안녕하세요 위와같이 다운받았는데도 불구하고 계속no module named tensorflow 라고 뜨고 anaconda navigator 을 들어가서 environment에 새로운 환경만들고 not installed 을 눌러서 확인해보면 tesorflow가 없습니다 ㅜㅜ estimator랑 다른것들은 있는데 왜그러는걸까요 2주째 다운이 안되어서 고생하구 있어요 도와주시면 정말 감사하겠습니다

    좋아요

    응답

  21. 저는 avx 미지원 cpu 이구.. python 3.6으로 다운그레이 하였습니다.
    “pip install tensorflow==1.5.0 ” 으로 설치하였습니다.
    컴퓨터 cpu 저사양 모델을 사용하시는 분들에게 추천합니다.
    그리고 중요한 마지막 포스팅에 빠진것 같은데..가상설정 마무리는
    “conda install jupyter notebook” 라구 쓰주어야 가상환경설정이 마무리됩니다.
    수많은 ㅠㅠ 시도끝에 성공한듯합니다.
    이글쓰주신 쥔장님을 비롯 여러댓글 분들 감사드립니다.

    좋아요

    응답

답글 남기기

아래 항목을 채우거나 오른쪽 아이콘 중 하나를 클릭하여 로그 인 하세요:

WordPress.com 로고

WordPress.com의 계정을 사용하여 댓글을 남깁니다. 로그아웃 /  변경 )

Google photo

Google의 계정을 사용하여 댓글을 남깁니다. 로그아웃 /  변경 )

Twitter 사진

Twitter의 계정을 사용하여 댓글을 남깁니다. 로그아웃 /  변경 )

Facebook 사진

Facebook의 계정을 사용하여 댓글을 남깁니다. 로그아웃 /  변경 )

%s에 연결하는 중